about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-24T17·01+0300
committertazjin <tazjin@tvl.su>2022-09-02T14·13+0000
commit2023b8e33f0e1700ecbaebf4c6fc37a479e73329 (patch)
tree3c22ab333c8671d228b47b13a690af8d7c69362c /tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix
parentc3b13416b02d8e0e68330408b107d3aad29e3a3f (diff)
fix(tvix/eval): consider `let ... inherit ...` in dynamic scopes r/4598
In conditions where no dynamic identifiers exist in a scope,
inheriting is usually a no-op - *unless* the identifier is not
statically known and the scope has a non-empty `with`-stack.

Change-Id: Iff4138d9cd4c56e844bc574203708dacc11c3f73
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6264
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix
new file mode 100644
index 0000000000..d335e53630
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-useless-inherit-with.nix
@@ -0,0 +1,15 @@
+# Normally using an `inherit` without a source attribute set within a
+# `let` is a no-op, *unless* there is a with in-scope that might
+# provide the value.
+
+# Provide a dynamic `x` identifier in the scope.
+with ({ x = 1;});
+
+# inherit this `x` as a static identifier
+let inherit x;
+
+# Provide another dynamic `x` identifier
+in with ({ x = 3; });
+
+# Inherited static identifier should have precedence
+x