about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-10T15·54-0400
committerclbot <clbot@tvl.fyi>2022-10-10T20·31+0000
commit4fd18cbc9a756ea51dd04fa7bde9cfc79f4f8fa3 (patch)
tree28b13aa1da306a365646ac2896fabf4b2283c73a /tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix
parent0b8a967acac26b527ebedfff6658117f63f7c861 (diff)
feat(tvix/eval): Implement builtins.tryEval r/5089
With asserts compiled using conditional jumps, this ends up being quite
straightforward - the only real tricky bit is that we have to know
whether an error can or can't be handled.

Change-Id: I75617da73b7a9c5cdd888c0e26ae81d2c5c0d714
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6924
Reviewed-by: sterni <sternenseemann@systemli.org>
Autosubmit: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix
new file mode 100644
index 0000000000..629bc440a8
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-tryeval.nix
@@ -0,0 +1,5 @@
+{
+  x = builtins.tryEval "x";
+  y = builtins.tryEval (assert false; "y");
+  z = builtins.tryEval (throw "bla");
+}