about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-03-15T13·42+0300
committerclbot <clbot@tvl.fyi>2024-03-15T14·22+0000
commitd3534ee051abad5117e9578854b6cd13a14d940d (patch)
tree258286ebf2c9390ef748a73f086ef6b4f80b4663 /tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix
parentd5b6704d3d82c1c1acf45aba71ab1a337f94defd (diff)
fix(depotfmt): only exclude *imported* tvix tests r/7699
When we added the Nix language test suite in cl/6126, we excluded the
whole tvix tests folder from Nix formatting. This is unintentional, as
we probably want *our* tests to be formatted correctly.

Change-Id: I2b66d79e30fae17e75d5a1f8c44e279886091c5f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11154
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix
index fea6e234dcfd..5997c99b47e5 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-parsedrvname.nix
@@ -1,12 +1,11 @@
-
 # the first dash followed by a non-alphabetic character separates
 # the "name" from the "version"
 
-assert builtins.parseDrvName "ripgrep-1.2"       == { name = "ripgrep";       version = "1.2"; };
-assert builtins.parseDrvName "rip-grep-1.2"      == { name = "rip-grep";      version = "1.2"; };
+assert builtins.parseDrvName "ripgrep-1.2" == { name = "ripgrep"; version = "1.2"; };
+assert builtins.parseDrvName "rip-grep-1.2" == { name = "rip-grep"; version = "1.2"; };
 assert builtins.parseDrvName "7zip_archiver-0.2" == { name = "7zip_archiver"; version = "0.2"; };
-assert builtins.parseDrvName "gcc-1-2"           == { name = "gcc";           version = "1-2"; };
-assert builtins.parseDrvName "bash--1-2"         == { name = "bash";          version = "-1-2"; };
-assert builtins.parseDrvName "xvidtune-?1-2"     == { name = "xvidtune";      version = "?1-2"; };
+assert builtins.parseDrvName "gcc-1-2" == { name = "gcc"; version = "1-2"; };
+assert builtins.parseDrvName "bash--1-2" == { name = "bash"; version = "-1-2"; };
+assert builtins.parseDrvName "xvidtune-?1-2" == { name = "xvidtune"; version = "?1-2"; };
 
 true