about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-29T15·40+0300
committertazjin <tazjin@tvl.su>2022-09-07T15·25+0000
commit786e12a7382eaaa957389b3a9e9e962efe7e8403 (patch)
treee86c9b9d96ab2d7bb480efe9eb52943c96d93d59 /tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix
parent9a783e50a490a873f157ec298165b3f38973e4b5 (diff)
feat(tvix/eval): always emit OpForce as the last instruction r/4689
Change-Id: Id70c987f654dc5d9b47db74e395281309762b468
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6353
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix
new file mode 100644
index 0000000000..133929dd19
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-nested-thunks.nix
@@ -0,0 +1,7 @@
+# If a thunk yields another thunk, OpForce should keep forcing until
+# there is a value.
+let
+  a = b;
+  b = c;
+  c = 42;
+in a