about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix
diff options
context:
space:
mode:
authorAdam Joseph <adam@westernsemico.com>2023-12-12T12·07-0800
committerclbot <clbot@tvl.fyi>2023-12-12T17·03+0000
commit7b9eea71d021315a1d29c2bcca84de72cc507e04 (patch)
treefa10a913125466e17899d98e1b7c27781f7315b3 /tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix
parentfc963033ae0f28a387d6aebcc1e827439f6653ef (diff)
fix(tvix/eval): fix nested assertions b/340 r/7190
This commit fixes our handling of `throw` within an `assert`
condition.

Fixes: b/340
Change-Id: I40a383639ec266da50a853f16216b1b7868495da
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10318
Autosubmit: Adam Joseph <adam@westernsemico.com>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix
new file mode 100644
index 0000000000..b0397e268e
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-nested-assertions.nix
@@ -0,0 +1 @@
+(builtins.tryEval (assert (assert false; true); true)).success