about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-03-15T13·42+0300
committerclbot <clbot@tvl.fyi>2024-03-15T14·22+0000
commitd3534ee051abad5117e9578854b6cd13a14d940d (patch)
tree258286ebf2c9390ef748a73f086ef6b4f80b4663 /tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
parentd5b6704d3d82c1c1acf45aba71ab1a337f94defd (diff)
fix(depotfmt): only exclude *imported* tvix tests r/7699
When we added the Nix language test suite in cl/6126, we excluded the
whole tvix tests folder from Nix formatting. This is unintentional, as
we probably want *our* tests to be formatted correctly.

Change-Id: I2b66d79e30fae17e75d5a1f8c44e279886091c5f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11154
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
index 89888fd561..551db72cb0 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
@@ -1,15 +1,16 @@
 with builtins;
 let
   fold = op: nul: list:
-    if list == []
+    if list == [ ]
     then nul
     else op (head list) (fold op nul (tail list));
   concat =
     fold (x: y: x + y) "";
-  asi = name: value : { inherit name value; };
-  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+  asi = name: value: { inherit name value; };
+  list = [ (asi "a" "A") (asi "b" "B") ];
   a = builtins.listToAttrs list;
-  b = builtins.listToAttrs ( list ++ list );
-  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+  b = builtins.listToAttrs (list ++ list);
+  r = builtins.listToAttrs [ (asi "result" [ a b ]) (asi "throw" (throw "this should not be thrown")) ];
   x = builtins.listToAttrs [ (asi "foo" "bar") (asi "foo" "bla") ];
-in concat (map (x: x.a) r.result) + x.foo
+in
+concat (map (x: x.a) r.result) + x.foo