about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-10T02·11-0400
committerclbot <clbot@tvl.fyi>2022-10-10T17·42+0000
commit8190046190dcce2844387729d0dbce6e5248ce41 (patch)
tree2fe5458f9393bfb0780cd9ee0145e876af052d0d /tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix
parentb0547ccfa5e74cf21e813cd18f64ef62f1bf3734 (diff)
feat(tvix/eval): Implement builtins.elem r/5080
Change-Id: Id99c1d33f87ad9866990d3483d3531e9e48f861f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6916
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix
new file mode 100644
index 0000000000..71ea7a4ed0
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-elem.nix
@@ -0,0 +1,6 @@
+with import ./lib.nix;
+
+let xs = range 10 40; in
+
+[ (builtins.elem 23 xs) (builtins.elem 42 xs) (builtins.elemAt xs 20) ]
+