about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-27T20·58+0300
committertazjin <tazjin@tvl.su>2022-09-06T07·29+0000
commita5e22c532b074cca80d15046e6aa109d9ca79a80 (patch)
tree7dff0f895d8efeecf35d31c6cdd9993aa882b85a /tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix
parente46a2ce3efd085d6e4a899d9dbc225c09c3ffd16 (diff)
fix(tvix/eval): correctly resolve dynamic upvalues one scope up r/4655
This does not yet correctly resolve them if they are more than one
scope up, however.

Change-Id: I6687073c60aee0282f2b6ffc98b34c1e96a60f20
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6319
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix
new file mode 100644
index 0000000000..7f1128b670
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-deeply-nested-with.nix
@@ -0,0 +1,6 @@
+with { a = 1; b = 1; };
+with { b = 2; c = 2; };
+with { c = 3; d = 3; };
+with { d = 4; };
+
+[ a b c d ]