about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-23T17·37-0400
committertazjin <tazjin@tvl.su>2022-10-29T10·45+0000
commitd0a836b0e1ee1034144d1e5b71df6ab285c8450e (patch)
tree73fd2ee2803af3d0a1617e7da3769cd5076091dd /tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix
parentb8a7dba709436eeb562f8911ae1b5691830d6fd7 (diff)
feat(tvix/eval): Implement comparison for lists r/5221
Lists are compared lexicographically in C++ nix as of [0], and our
updated nix test suites depend on this. This implements comparison of
list values in `Value::nix_cmp` using a very similar algorithm to what
C++ does - similarly to there, this requires passing in the VM so we can
force thunks in the list elements as we go.

[0]: https://github.com/NixOS/nix/commit/09471d2680292af48b2788108de56a8da755d661#

Change-Id: I5d8bb07f90647a1fec83f775243e21af856afbb1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7070
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix
new file mode 100644
index 0000000000..9b73df61d8
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-compare-lists.nix
@@ -0,0 +1,17 @@
+[
+  ([1 2] < [1])
+  ([1 2] < [2 3])
+  ([1 2] < [2])
+  ([1 2] < [1 2 3])
+  ([3 4] < [1])
+  ([1 2] > [1])
+  ([1 2] > [2 3])
+  ([1 2] > [2])
+  ([1 2] > [1 2 3])
+  ([3 4] > [1])
+  ([1 2] <= [1])
+  ([1 2] >= [2 3])
+  ([1 2] >= [2])
+  ([1 2] <= [1 2 3])
+  ([3 4] >= [1])
+]