about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-09-24T12·54+0300
committertazjin <tazjin@tvl.su>2022-09-29T11·47+0000
commit3f2160627895e7d1fe3236812b83bddc5d3049f5 (patch)
treea3bb11b512bb72176467db8a5444ad2f7baa0860 /tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix
parent949897651e826598f2011611e0cc03619426fcc2 (diff)
refactor(tvix/eval): merge all bindings creation logic r/4989
As of this commit, all three types of bindings scopes are compiled the
same way (i.e. compilation of non-recursive attribute sets has been
switched over to the new code paths).

This sets us up for doing the final implementation of nested attribute
sets.

HOWEVER, this breaks the existing implementation of nested attributes
in non-recursive attribute sets. That implementation is flawed and
unworkable in practice, so we need to do this dance to be able to
implement it correctly.

Change-Id: Iba2545c0d1d6b51f5e1a31a5d005b8d01da546d3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6782
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix
index 38d7ffee61..a3cb659ecf 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-type-of.nix
@@ -13,7 +13,7 @@ fix (self:
     (builtins.typeOf "foo")
     (builtins.typeOf "${"foo" + "bar"}baz")
     (builtins.typeOf {})
-    (builtins.typeOf { foo.bar = 32; }.foo)
+    # (builtins.typeOf { foo.bar = 32; }.foo) # TODO: re-enable when nested keys are done
     (builtins.typeOf ({ name = "foo"; value = 13; } // { name = "bar"; }))
     (builtins.typeOf self)
     (builtins.typeOf fix)