about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-10T11·52+0300
committerclbot <clbot@tvl.fyi>2023-01-12T10·42+0000
commit02d35e4aa6ef84cdbd01d881bdc5c1acd50fc7dc (patch)
tree86e4a57d551e8c47debbc703d3db3ac106677a22 /tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix
parentfc7e52b4acc3f70968d0c063942b106da31eb8aa (diff)
feat(tvix/eval): implement builtins.toJSON r/5652
Implements `Serialize` for `tvix_eval::Value`. Special care is taken
with serialisation of attribute sets, and forcing of thunks.

The tests should cover both cases well.

Change-Id: I9bb135bacf6f87bc6bd0bd88cef0a42308e6c335
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7803
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix
new file mode 100644
index 0000000000..16234ab451
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-tojson-thunks.nix
@@ -0,0 +1,9 @@
+let
+  a = b * 2;
+  b = 21;
+in
+builtins.toJSON [
+  a
+  ((n: n * 2) 21)
+  (builtins.toJSON a)
+]