about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix
diff options
context:
space:
mode:
authorAspen Smith <root@gws.fyi>2024-02-10T15·26-0500
committerclbot <clbot@tvl.fyi>2024-02-20T23·53+0000
commit5ced8e7292384fc93dd8dad652c2612be4ba5d4a (patch)
treeb1ec8a7852dad9f4901daba6aabf40a930cd91de /tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix
parent1b233024c7ffcf1acceec5431cf2100b837d31db (diff)
fix(tvix/eval): Propagate catchables in builtins.groupBy r/7580
One last place where we needed to wrap the forcing of the element of a
list in `try_value!`. This fixes a previously `notyetpassing` test

Change-Id: I8827a3e39630e6959013b70bdfa9cbcb93f4e91c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10789
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix
new file mode 100644
index 000000000000..182601abb18c
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-group-by-propagate-catchable.nix
@@ -0,0 +1,5 @@
+map (e: (builtins.tryEval e).success) [
+  (builtins.groupBy (builtins.throw "a") [ "" ])
+  (builtins.groupBy (x: true) (builtins.throw "b"))
+  (builtins.groupBy (_: builtins.throw "x") [ "" ])
+]