about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-03-15T13·42+0300
committerclbot <clbot@tvl.fyi>2024-03-15T14·22+0000
commitd3534ee051abad5117e9578854b6cd13a14d940d (patch)
tree258286ebf2c9390ef748a73f086ef6b4f80b4663 /tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix
parentd5b6704d3d82c1c1acf45aba71ab1a337f94defd (diff)
fix(depotfmt): only exclude *imported* tvix tests r/7699
When we added the Nix language test suite in cl/6126, we excluded the
whole tvix tests folder from Nix formatting. This is unintentional, as
we probably want *our* tests to be formatted correctly.

Change-Id: I2b66d79e30fae17e75d5a1f8c44e279886091c5f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11154
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix
index 234c95040b67..c11a21ce1e95 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-builtins-foldl-propagate-catchable.nix
@@ -1,8 +1,8 @@
 map (e: (builtins.tryEval e).success) [
-  (builtins.foldl' (builtins.throw "a") {} [ {} {} {} ])
-  (builtins.foldl' (x: y: x // y) {} (builtins.throw "b"))
-  (builtins.foldl' (_: _: builtins.throw "x") {} [ {} ])
-  (builtins.foldl' (x: y: x // y) (builtins.throw "x") [ {} ])
-  (builtins.foldl' (x: y: x // y) {} [ {} { a = builtins.throw "z"; } {} ])
-  (builtins.foldl' (x: y: x // y) {} [ {} { b = 3; a = builtins.throw "u"; } {} ])
+  (builtins.foldl' (builtins.throw "a") { } [{ } { } { }])
+  (builtins.foldl' (x: y: x // y) { } (builtins.throw "b"))
+  (builtins.foldl' (_: _: builtins.throw "x") { } [{ }])
+  (builtins.foldl' (x: y: x // y) (builtins.throw "x") [{ }])
+  (builtins.foldl' (x: y: x // y) { } [{ } { a = builtins.throw "z"; } { }])
+  (builtins.foldl' (x: y: x // y) { } [{ } { b = 3; a = builtins.throw "u"; } { }])
 ]