about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-03-03T20·55+0300
committertazjin <tazjin@tvl.su>2023-03-13T20·30+0000
commit7d339d27627de12e7dc99f823e84c381281babfc (patch)
treea26c6e2408677b34bc4ff1059452f8e69605823f /tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix
parenta9f44721e51a189349910a5cf95e1071b01632a1 (diff)
fix(tvix/eval): handle `__toString` when JSON-serialising attrsets r/5976
These must be serialised to a JSON string of the *result* of coercing
the function application to a string.

Change-Id: Ib7f49ccd950503ddbdbf99643cd59565e26b50da
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8204
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix b/tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix
new file mode 100644
index 0000000000..345b76fde0
--- /dev/null
+++ b/tvix/eval/src/tests/tvix_tests/eval-fail-builtins-tojson-tostring-notcallable.nix
@@ -0,0 +1,5 @@
+# attribute sets with a non-callable `__toString` can not be
+# serialised to JSON.
+builtins.toJSON {
+  __toString = 42;
+}