about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-10-19T14·36+0200
committerclbot <clbot@tvl.fyi>2022-10-20T02·33+0000
commit8e188d623591871944c5d8626921747333454e9e (patch)
treef4d05c7772ca4f65aab03c0ee008af3dca63ff7d /tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix
parente3637136d134dd8cd5c38af76fe69fa5cb11a297 (diff)
test(tvix/eval): update C++ Nix test suite to current master r/5164
The language test suite actually doesn't require flakes and the
new features are mostly sensible (added builtins) as well as some
tests for regressions the C++ implementation experienced.

The path interpolation test is not included in this update because there
is no way to construct an location-independent .exp file for it (the C++
repo also doesn't have one). We may still want to implement that feature
eventually (in case rnix adds support for it).

The C++ Nix revision used is ac0fb38e8a5a25a84fa17704bd31b453211263eb.

Change-Id: I75f1e780ddeeee6f6b1f28cf3c66c288dca2c20c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7043
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix b/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix
index 8299c3a4a3..50aa78e403 100644
--- a/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix
+++ b/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-sort.nix
@@ -4,5 +4,17 @@ with builtins;
   (sort (x: y: y < x) [ 483 249 526 147 42 77 ])
   (sort lessThan [ "foo" "bar" "xyzzy" "fnord" ])
   (sort (x: y: x.key < y.key)
-    [ { key = 1; value = "foo"; } { key = 2; value = "bar"; } { key = 1; value = "fnord"; } ]) 
+    [ { key = 1; value = "foo"; } { key = 2; value = "bar"; } { key = 1; value = "fnord"; } ])
+  (sort lessThan [
+    [ 1 6 ]
+    [ ]
+    [ 2 3 ]
+    [ 3 ]
+    [ 1 5 ]
+    [ 2 ]
+    [ 1 ]
+    [ ]
+    [ 1 4 ]
+    [ 3 ]
+  ])
 ]