about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-10T15·53+0300
committertazjin <tazjin@tvl.su>2022-08-24T21·25+0000
commit92c53fe982560248dc7655a5605db5e3cfc35d04 (patch)
tree567f8bf95bbc3ae7e10e262c589769c05a372056 /tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix
parentb28da8ad56bd0d5dbf58926241060a6e4d34908b (diff)
feat(tvix/tests): check in Nix' language test suite r/4461
This adds scaffolding code for running the Nix language test suite.

The majority of eval-okay-* tests should eventually be runnable as-is
by Tvix, however the eval-fail-* tests might not as we intend to have
more useful error messages than upstream Nix.

Change-Id: I4f3227f0889c55e4274b804a3072850fb78dd1bd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6126
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix b/tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix
new file mode 100644
index 0000000000..96fd25a015
--- /dev/null
+++ b/tvix/eval/src/tests/nix_tests/eval-okay-patterns.nix
@@ -0,0 +1,16 @@
+let
+
+  f = args@{x, y, z}: x + args.y + z;
+
+  g = {x, y, z}@args: f args;
+
+  h = {x ? "d", y ? x, z ? args.x}@args: x + y + z;
+
+  j = {x, y, z, ...}: x + y + z;
+
+in
+  f {x = "a"; y = "b"; z = "c";} +
+  g {x = "x"; y = "y"; z = "z";} +
+  h {x = "D";} +
+  h {x = "D"; y = "E"; z = "F";} +
+  j {x = "i"; y = "j"; z = "k"; bla = "bla"; foo = "bar";}