about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2022-10-23T16·28-0400
committergrfn <grfn@gws.fyi>2022-10-24T13·44+0000
commit7b3bda9e089fe9de2d28a28f64ef8532abb3ac9c (patch)
tree14b0a70c2977daec417a958e78547a39094d5ab7 /tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix
parent8497b83569761e6cb67b355f395d45ef8b02ee80 (diff)
feat(tvix/eval): Implement builtins.mapAttrs r/5192
I played around a little bit with doing this in-place, but ended up
going with this perhaps slightly clone-heavy approach for now because
ideally most clones on Value are cheap - but later we should benchmark
alternate approaches that get to reuse allocations better if necessary
or possible.

Change-Id: If998eb2056cedefdf2fb480b0568ac8329ccfc44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7068
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix b/tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix
new file mode 100644
index 000000000000..f075b6275e5a
--- /dev/null
+++ b/tvix/eval/src/tests/nix_tests/eval-okay-mapattrs.nix
@@ -0,0 +1,3 @@
+with import ./lib.nix;
+
+builtins.mapAttrs (name: value: name + "-" + value) { x = "foo"; y = "bar"; }