about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-hashfile.nix
diff options
context:
space:
mode:
authorPadraic-O-Mhuiris <patrick.morris.310@gmail.com>2024-02-22T15·33+0000
committerPádraic Ó Mhuiris <patrick.morris.310@gmail.com>2024-02-29T10·58+0000
commite0ffb4d47a9fb52c8ea3b0d8b1d002606b0bc4ee (patch)
tree3b739852313336e8c77f7fca7491ac9fc996ee3f /tvix/eval/src/tests/nix_tests/eval-okay-hashfile.nix
parent5acaa672acbfdf0d9355435a2acce07f3f07d37a (diff)
feat(tvix/eval): implement `builtins.hashFile` r/7625
The primary addition is the `builtin_hashFile` function which attempts
value-path coercion and on success reads the file to a nix_string.
Similar to the `builtins_hashString` implementation, the hash is then
derived using the `hash_nix_string` function in the introduced hash
module which has extracted hashing functionality initially specified in
cl/11005.

Change-Id: I5e3ef0317223af99488ebb79efc2fb49b4cbc1b6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11007
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to '')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-hashfile.nix (renamed from tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-hashfile.nix)2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-hashfile.nix b/tvix/eval/src/tests/nix_tests/eval-okay-hashfile.nix
index 8c9de66b7e..aff5a18568 100644
--- a/tvix/eval/src/tests/nix_tests/notyetpassing/eval-okay-hashfile.nix
+++ b/tvix/eval/src/tests/nix_tests/eval-okay-hashfile.nix
@@ -1,4 +1,4 @@
 let
-  paths = [ ./../data ./../binary-data ];
+  paths = [ ./data ./binary-data ];
 in
   builtins.concatLists (map (hash: map (builtins.hashFile hash) paths) ["md5" "sha1" "sha256" "sha512"])