about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix
diff options
context:
space:
mode:
authorAdam Joseph <adam@westernsemico.com>2022-10-18T04·31-0700
committerclbot <clbot@tvl.fyi>2022-10-19T15·01+0000
commitf991ff929401df79d4ad2320bf3e796c935e830a (patch)
treebe311b37a8c59c7bf14859d69c637c532079850b /tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix
parent2bc38ce7dc96c41c674bc2e33dba3286111b0e5d (diff)
feat(tvix/eval): expect not-yet-passing tests to fail r/5161
It is helpful to be able to use the test suite as a regression test:
make a change to the compiler/vm, re-run the tests, and if there are
any failures you know it's your fault.

Right now we can't do that, because the expected-to-fail tests are
mixed in with the expected-to-pass tests.  So we can't use them as a
regression test.

Change-Id: Ied606882b9835a7effd7e75bfcf3e5f827e0a2c8
Signed-off-by: Adam Joseph <adam@westernsemico.com>
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7036
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix b/tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix
deleted file mode 100644
index 102ee82b5e6b..000000000000
--- a/tvix/eval/src/tests/nix_tests/eval-okay-fromjson.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-# RFC 7159, section 13.
-builtins.fromJSON
-  ''
-    {
-      "Image": {
-          "Width":  800,
-          "Height": 600,
-          "Title":  "View from 15th Floor",
-          "Thumbnail": {
-              "Url":    "http://www.example.com/image/481989943",
-              "Height": 125,
-              "Width":  100
-          },
-          "Animated" : false,
-          "IDs": [116, 943, 234, 38793, true  ,false,null, -100],
-          "Latitude":  37.7668,
-          "Longitude": -122.3959
-        }
-    }
-  ''
-==
-  { Image =
-    { Width = 800;
-      Height = 600;
-      Title = "View from 15th Floor";
-      Thumbnail =
-        { Url = http://www.example.com/image/481989943;
-          Height = 125;
-          Width = 100;
-        };
-      Animated = false;
-      IDs = [ 116 943 234 38793 true false null (0-100) ];
-      Latitude = 37.7668;
-      Longitude = -122.3959;
-    };
-  }