about summary refs log tree commit diff
path: root/tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix
diff options
context:
space:
mode:
authorAdam Joseph <adam@westernsemico.com>2022-10-18T04·31-0700
committerclbot <clbot@tvl.fyi>2022-10-19T15·01+0000
commitf991ff929401df79d4ad2320bf3e796c935e830a (patch)
treebe311b37a8c59c7bf14859d69c637c532079850b /tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix
parent2bc38ce7dc96c41c674bc2e33dba3286111b0e5d (diff)
feat(tvix/eval): expect not-yet-passing tests to fail r/5161
It is helpful to be able to use the test suite as a regression test:
make a change to the compiler/vm, re-run the tests, and if there are
any failures you know it's your fault.

Right now we can't do that, because the expected-to-fail tests are
mixed in with the expected-to-pass tests.  So we can't use them as a
regression test.

Change-Id: Ied606882b9835a7effd7e75bfcf3e5f827e0a2c8
Signed-off-by: Adam Joseph <adam@westernsemico.com>
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7036
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix')
-rw-r--r--tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix b/tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix
deleted file mode 100644
index 3fb023e1cd42..000000000000
--- a/tvix/eval/src/tests/nix_tests/eval-okay-delayed-with.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-let
-
-  pkgs_ = with pkgs; {
-    a = derivation {
-      name = "a";
-      system = builtins.currentSystem;
-      builder = "/bin/sh";
-      args = [ "-c" "touch $out" ];
-      inherit b;
-    };
-
-    b = derivation {
-      name = "b";
-      system = builtins.currentSystem;
-      builder = "/bin/sh";
-      args = [ "-c" "touch $out" ];
-      inherit a;
-    };
-
-    c = b;
-  };
-
-  packageOverrides = pkgs: with pkgs; {
-    b = derivation (b.drvAttrs // { name = "${b.name}-overridden"; });
-  };
-
-  pkgs = pkgs_ // (packageOverrides pkgs_);
-
-in "${pkgs.a.b.name} ${pkgs.c.name} ${pkgs.b.a.name}"