about summary refs log tree commit diff
path: root/tvix/eval/builtin-macros/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·54+0300
committerclbot <clbot@tvl.fyi>2024-08-29T14·37+0000
commit5a97888d8b9df1815cee3d577ea95a44f188434f (patch)
treebdda1eb049d9e8b607ba71bc9e7cb1e2e5dd769f /tvix/eval/builtin-macros/Cargo.toml
parent2945a359b46862b3da79dec37fa8ccb2f751fa8a (diff)
chore(tvix): Migrate members to inherit deps from workspace r/8610
From now on we will add the dependencies and their version in the root
Cargo.toml and in order to enable the dependency for a workspace member
we set `workspace = true` in the member's Cargo.toml.

Change-Id: I9738c1cf99810b7ace87ca712c3ea965ba846e25
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12389
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/eval/builtin-macros/Cargo.toml')
-rw-r--r--tvix/eval/builtin-macros/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/eval/builtin-macros/Cargo.toml b/tvix/eval/builtin-macros/Cargo.toml
index 0171bb9ae62d..0696d742b342 100644
--- a/tvix/eval/builtin-macros/Cargo.toml
+++ b/tvix/eval/builtin-macros/Cargo.toml
@@ -6,8 +6,8 @@ edition = "2021"
 
 [dependencies]
 syn = { version = "1.0.109", features = ["full", "parsing", "printing", "visit", "visit-mut", "extra-traits"] }
-quote = "1.0.37"
-proc-macro2 = "1"
+quote = { workspace = true }
+proc-macro2 = { workspace = true }
 
 [lib]
 proc-macro = true