about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-08T21·19+0300
committerclbot <clbot@tvl.fyi>2022-12-21T13·09+0000
commitd9e2bec953880ecb5953b61b36a5beaec0565e22 (patch)
tree928d61f4bfd8d98dbe194284285c4f75186ee4f1 /tvix/eval/Cargo.toml
parent1138fbcaad3a7d69f707c4f47d84f314bc95d45a (diff)
refactor(tvix): split binary (REPL etc.) out from evaluator library r/5440
The tvix-eval project is independent from any *uses* of the evaluator,
such as the tvix-repl.

This functionality has been split out into a separate "tvix-cli"
crate. Note that this doesn't have to mean that this CLI crate is the
"final" CLI crate for tvix, the point of this is not "getting the CLI
structure right" but rather "getting the evaluator structure right".

This reshuffling is part of restructuring the way that functionality
like store communication is injected into language evaluation.

Note that at this commit the new CLI crate is not at feature-parity.

Change-Id: Id0af03dc8e07ef09a9f882a89612ad555eca8f93
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7541
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 1b24f64013..e4282507d7 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -8,13 +8,8 @@ edition = "2021"
 [lib]
 name = "tvix_eval"
 
-[[bin]]
-name = "tvix-eval"
-required-features = [ "repl" ]
-
 [dependencies]
 smol_str = "0.1"
-rustyline = { version = "10.0.0", optional = true }
 dirs = "4.0.0"
 path-clean = "0.1"
 tabwriter = "1.2"
@@ -23,7 +18,6 @@ codemap = "0.1.3"
 codemap-diagnostic = "0.1.1"
 proptest = { version = "1.0.0", default_features = false, features = ["std", "alloc", "break-dead-code", "tempfile"], optional = true }
 test-strategy = { version = "0.2.1", optional = true }
-clap = { version = "3.2.22", optional = true, features = ["derive", "env"] }
 serde = "1.0"
 serde_json = "1.0"
 regex = "1.6.0"
@@ -39,15 +33,12 @@ itertools = "0.10.3"
 tempdir = "0.3.7"
 
 [features]
-default = [ "repl", "impure", "arbitrary", "nix_tests", "backtrace_overflow" ]
+default = [ "impure", "arbitrary", "nix_tests", "backtrace_overflow" ]
 
 # Enables running the Nix language test suite from the original C++
 # Nix implementation (at version 2.3) against Tvix.
 nix_tests = []
 
-# Enables building the binary (tvix-eval REPL)
-repl = [ "rustyline", "clap" ]
-
 # Enables operations in the VM which depend on the ability to perform I/O
 impure = []