about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-08-12T15·52+0300
committertazjin <tazjin@tvl.su>2022-08-28T11·02+0000
commitde21d201ba7bca518ebbcfa091cdff94d7ea152e (patch)
treee2503b919bc723de9bcd9a92b393a34fe5ea72bd /tvix/eval/Cargo.toml
parent6fe5e2d75257504f0321e2e98b6fb675b716fe25 (diff)
fix(tvix/eval): use path_clean instead of fs::canonicalize for paths r/4520
Canonicalisation performs much more functionality than what C++ Nix
implements for paths, and causes some undesirable behaviour (e.g.
handling non-existant files becomes difficult, but should be possible
in literals).

Instead, the path_clean crate provides a pure normalisation method.

There is an intention to add this to Rust itself:
https://github.com/rust-lang/rfcs/issues/2208

Change-Id: I775d238136db0a52cf6b12a68985833c8fb32882
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6186
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index b4cf604675..836b5deed1 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -10,6 +10,7 @@ rnix = "0.10.2"
 smol_str = "0.1"
 rustyline = "10.0.0"
 dirs = "4.0.0"
+path-clean = "0.1"
 
 [dev-dependencies]
 criterion = "0.3.6"