about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-09-07T19·29+0300
committerclbot <clbot@tvl.fyi>2024-09-25T18·18+0000
commitc1e69e260dc9025e7c1ff04131f336cd45ca72e9 (patch)
treea531f875d3dd8d1cde0caca5d96e83b615801807 /tvix/eval/Cargo.toml
parent1bdf5c0c118020e897d8810df7a4e70c613e3c7f (diff)
feat(tvix/eval): Use thiserror for ErrorKind and CatchableErrorKind r/8713
thiserror is much more easier to maintain than manually implementing Error and Display.

Change-Id: Ibf13e2d8a96fba69c8acb362b7515274a593dfd6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12452
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index c99bea4f7125..29862f97d8e4 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -36,6 +36,7 @@ data-encoding = { workspace = true }
 rustc-hash = { workspace = true }
 nohash-hasher = { workspace = true }
 vu128 = { workspace = true }
+thiserror.workspace = true
 
 [dev-dependencies]
 criterion = { workspace = true }