about summary refs log tree commit diff
path: root/tvix/derivation/Cargo.toml
diff options
context:
space:
mode:
authorJürgen Hahn <mail.jhahn@gmail.com>2023-01-02T15·09+0100
committerjrhahn <mail.jhahn@gmail.com>2023-01-04T12·24+0000
commit6f993b8bde8201213fe2953ea663ac387de916e3 (patch)
treef82cd8094172c18a5eb0601f278fa4205e48344c /tvix/derivation/Cargo.toml
parent79c05f38109d2eac07b9ba893b9b6f67fd34c29c (diff)
feat(tvix/derivation): add nix drv path generation to Derivation r/5580
This adds a function to generate the derivation path. The computation
is based on the Go implementation.

Change-Id: Iae89db4976f5fd9208f0453f73688689a245cd66
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7729
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/derivation/Cargo.toml')
-rw-r--r--tvix/derivation/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/derivation/Cargo.toml b/tvix/derivation/Cargo.toml
index 99dfbb3a10..ec998c4465 100644
--- a/tvix/derivation/Cargo.toml
+++ b/tvix/derivation/Cargo.toml
@@ -8,6 +8,8 @@ edition = "2021"
 [dependencies]
 glob = "0.3.0"
 serde = { version = "1.0", features = ["derive"] }
+sha2 = "0.10.6"
+tvix-store-bin = { path = "../store" }
 
 [dev-dependencies.test-generator]
 # This fork of test-generator adds support for cargo workspaces, see
@@ -17,3 +19,4 @@ rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
 
 [dev-dependencies]
 serde_json = "1.0"
+test-case = "2.2.2"