about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-07-30T19·35+0300
committerclbot <clbot@tvl.fyi>2024-07-31T20·07+0000
commit13720d90bf1ad63deefda3e9e5ca3c187267c989 (patch)
treec3e3de1bbc4268dd410a5ce3fc258e1969928310 /tvix/default.nix
parent7cfac04b7ddab313a894eb57c654d7c0a9babb41 (diff)
fix(tvix): Reuse now exposed depotfmt wrapper in crate2nix-check r/8433
This change exposes the already existing wrapper for treefmt/depotfmt
that supports running it inside a sandbox. We now reuse it inside
//tvix/crate2nix-check, where we previously duplicated the code. The
check is now stricter and will also fail on changes, so I had to set the
rust edition in the treefmt config.

Change-Id: I000e52421258979c038ba6b1f1ff2db14e391b0c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12068
Tested-by: BuildkiteCI
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index f8aa47a108c5..0d833eb1e50a 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -73,11 +73,8 @@ in
         cargo metadata > /dev/null
 
         ${pkgs.crate2nix}/bin/crate2nix generate --all-features
-        ${pkgs.treefmt}/bin/treefmt Cargo.nix \
-          --no-cache \
-          --on-unmatched=debug \
-          --config-file=${depot.tools.depotfmt.config} \
-          --tree-root=.
+        # Reuse depotfmt wrapper that can be used inside a sandbox.
+        ${depot.tools.depotfmt.check} Cargo.nix
 
         # technically unnecessary, but provides more-helpful output in case of error
         diff -ur Cargo.nix ${src}/Cargo.nix