about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorSimon Hauser <simon.hauser@helsinki-systems.de>2024-06-06T13·44+0200
committerclbot <clbot@tvl.fyi>2024-06-10T16·35+0000
commit825d498908e2f6c9fdca3225afefb0aa4b3cc747 (patch)
tree765e5412bf24ae41bb3d6f42791a229b68a88451 /tvix/default.nix
parent11a6ff77067a7b9eec3f1c15412d7143cb85a047 (diff)
feat(tvix/tracing): introduce common tvix-tracing crate r/8242
Introduce a new common crate that contains tracing boilerplate which then
can be used in the cli, tvix-store and tvix-build crates.
It has otlp as an optional feature, which is currently only used by
tvix-store.

Change-Id: I41468ac4d9c65174515d721513b96fea463d6ed2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11758
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Simon Hauser <simon.hauser@helsinki-systems.de>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index edcae8dd0795..e1b8781ba603 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -128,6 +128,10 @@ let
         src = filterRustCrateSrc { root = prev.src.origSrc; };
       };
 
+      tvix-tracing = prev: {
+        src = filterRustCrateSrc { root = prev.src.origSrc; };
+      };
+
       nix-compat = prev: {
         src = filterRustCrateSrc rec {
           root = prev.src.origSrc;