about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-03-19T10·12+0200
committerclbot <clbot@tvl.fyi>2024-04-09T15·50+0000
commit17849c5c0033fa1909f0403b5d5e6a5e018b7fee (patch)
tree986cb431e779b067183756b01c39cf9644cb583a /tvix/default.nix
parent84ad8a0bbd19f1058e0ab2feac07f9d44f275be3 (diff)
feat(tvix/castore/directory): add bigtable backend r/7881
This adds a Directory service using
https://cloud.google.com/bigtable/docs/ as a K/V store.

Directory (closures) are put in individual keys.

We don't do any bucketed upload of directory closures (yet), as castore/
fs does query individually, does not request recursively (and buffers).
This will be addressed by store composition at some point.

Change-Id: I7fada45bf386a78b7ec93be38c5f03879a2a6e22
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11212
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index da3e0ca605..f965959c91 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -43,6 +43,10 @@ let
         nativeBuildInputs = protobufDep prev;
       };
 
+      prost-wkt-types = prev: {
+        nativeBuildInputs = protobufDep prev;
+      };
+
       tonic-reflection = prev: {
         nativeBuildInputs = protobufDep prev;
       };
@@ -84,6 +88,7 @@ let
         (crateName:
           (lib.nameValuePair "${crateName}-${crates.internal.crates.${crateName}.version}" crates.internal.crates.${crateName}.src.outputHash)
         ) [
+        "bigtable_rs"
         "test-generator"
         "wu-manber"
       ]);