about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-26T06·50+0300
committerclbot <clbot@tvl.fyi>2023-09-26T10·03+0000
commit10717605a2ceb736d1c1ad215f8a92ef30dd85c3 (patch)
tree4348ceeb75fb028348746b9ef57c300d26857a2e /tvix/default.nix
parent15a3eca321c7f02da26df3c2ae4acc7a3f07f18e (diff)
chore(third_party/crate2nix): bump crate2nix to current HEAD r/6657
This will bring conditional features support.

Also invoke crate2nixgenerate with the --all-features argument, so all
dependencies, including the ones for optional features are included in
the Cargo.nix file.

Change-Id: I3bbcb200c9b481f660db89efba650ea4f7418a63
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9470
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 57ff82bf2e..d8027213f6 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -72,7 +72,7 @@ in
   # Run crate2nix generate in the current working directory, then
   # format the generated file with depotfmt.
   crate2nixGenerate = pkgs.writeShellScriptBin "crate2nix-generate" ''
-    ${pkgs.crate2nix}/bin/crate2nix generate
+    ${pkgs.crate2nix}/bin/crate2nix generate --all-features
     ${depot.tools.depotfmt}/bin/depotfmt Cargo.nix
   '';