about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-09T08·49+0200
committerclbot <clbot@tvl.fyi>2023-12-11T21·43+0000
commitfd27d8ddc3a27fd89a3a132343c6a1ad8da3671c (patch)
treeaf891877cb4a0ca5e45f8bc59b29a0f7906dba69 /tvix/default.nix
parent3c0a9a949ab71545de23102a8309ad0bea591c1f (diff)
feat(tvix/build): init r/7151
This adds the tvix-build crate, currently only containing a
`tvix_build::proto` module, exposing the data structures defined in
tvix/build/protos.

Change-Id: I75f5d9196969ed0877b1fe640cacfecba0fb2e03
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10235
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index a6878f3c15..ac800ce6a1 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -40,6 +40,11 @@ let
         nativeBuildInputs = protobufDep prev;
       };
 
+      tvix-build = prev: {
+        PROTO_ROOT = depot.tvix.proto;
+        nativeBuildInputs = protobufDep prev;
+      };
+
       tvix-castore = prev: {
         PROTO_ROOT = depot.tvix.proto;
         nativeBuildInputs = protobufDep prev;