about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-05T20·08+0200
committerclbot <clbot@tvl.fyi>2023-12-05T21·55+0000
commit41235bf9086c6b048549c7564679d748c35e0de3 (patch)
treecc8666eee6040b58dbb909cb649a06e445a5fc17 /tvix/default.nix
parent88028d12694df54f0cc912dcc4597a25e4b1ea5a (diff)
refactor(tvix): move src into let binding r/7118
Change-Id: Ida2a3ac722fb2445745759323975884dfeef3e87
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10193
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 30235b4389..f6ab256ed4 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -85,6 +85,10 @@ let
         "futures-util"
       ]);
   };
+
+  # The cleaned sources.
+  src = depot.third_party.gitignoreSource ./.;
+
 in
 {
   inherit crates;
@@ -117,9 +121,8 @@ in
 
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
-    inherit cargoDeps;
+    inherit cargoDeps src;
     name = "tvix-rust-docs";
-    src = depot.third_party.gitignoreSource ./.;
     PROTO_ROOT = depot.tvix.proto;
 
     nativeBuildInputs = with pkgs; [
@@ -143,9 +146,8 @@ in
   # Run cargo clippy. We run it with -Dwarnings, so warnings cause a nonzero
   # exit code.
   clippy = pkgs.stdenv.mkDerivation {
-    inherit cargoDeps;
+    inherit cargoDeps src;
     name = "tvix-clippy";
-    src = depot.third_party.gitignoreSource ./.;
     PROTO_ROOT = depot.tvix.proto;
 
     buildInputs = [