about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-17T20·00+0100
committerflokli <flokli@flokli.de>2023-10-17T20·25+0000
commit45d8a78a8b39561622fafdc495edf2dbac49465d (patch)
treec9bea8fdd02df4d7525cb91cb6853333769d5b7c /tvix/default.nix
parentc4ea2053877f3560b349b6f339f78baca4b06290 (diff)
chore(tvix): move regenerate scripts to passthru r/6846
This keeps things isolated a bit more.

Change-Id: I437f2f63ee1567c0cbc02298514ad4d89f1dce85
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9790
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix10
1 files changed, 0 insertions, 10 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 28e64d574a..43b942cef0 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -106,16 +106,6 @@ in
   # workspace too.
   shell = (import ./shell.nix { inherit pkgs; });
 
-  # Update `.pb.go` files in tvix/castore-go with the generated ones.
-  castore-go-generate = pkgs.writeShellScriptBin "castore-go-protogen" ''
-    (cd $(git rev-parse --show-toplevel)/tvix/castore-go && rm *.pb.go && cp ${depot.tvix.castore.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
-  '';
-
-  # Update `.pb.go` files in tvix/store-go with the generated ones.
-  store-go-generate = pkgs.writeShellScriptBin "store-go-protogen" ''
-    (cd $(git rev-parse --show-toplevel)/tvix/store-go && rm *.pb.go && cp ${depot.tvix.store.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
-  '';
-
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
     inherit cargoDeps;