about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-17T12·42+0100
committerflokli <flokli@flokli.de>2023-10-17T19·51+0000
commit1b26bf21e3305232b9bbdc928a063da9be9eaee0 (patch)
treed5ee335a6c76cc54095266ec685e4a8dae515a2e /tvix/default.nix
parente38733a955f6f6fc8962cf0e669d9cf4696bc14d (diff)
chore(tvix): move store golang bindings to tvix/store-go r/6844
Similar to the castore-go CL before, this also updates the store-go
bindings to the new layout.

Change-Id: Id73d7ad43f7d70171ab021728e303300c5db71f0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9788
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 3365fe7981..28e64d574a 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -111,12 +111,10 @@ in
     (cd $(git rev-parse --show-toplevel)/tvix/castore-go && rm *.pb.go && cp ${depot.tvix.castore.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
   '';
 
-  # Builds and tests the code in store/protos.
-  store-protos-go = pkgs.buildGoModule {
-    name = "store-golang";
-    src = depot.third_party.gitignoreSource ./store/protos;
-    vendorHash = "sha256-WAYaIT3h3Cdvo1RB8T7DuoxeKvXfkq8vo/vdkhJQDs0=";
-  };
+  # Update `.pb.go` files in tvix/store-go with the generated ones.
+  store-go-generate = pkgs.writeShellScriptBin "store-go-protogen" ''
+    (cd $(git rev-parse --show-toplevel)/tvix/store-go && rm *.pb.go && cp ${depot.tvix.store.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
+  '';
 
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
@@ -144,7 +142,6 @@ in
   };
 
   meta.ci.targets = [
-    "store-protos-go"
     "shell"
     "rust-docs"
   ];