about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-07T14·51+0300
committerflokli <flokli@flokli.de>2023-09-10T13·13+0000
commitafe4dfb61eee59d03a883eba638beb685bf67447 (patch)
tree0692875093981b513bc5103cdb7e9a5818242a50 /tvix/default.nix
parent9786255267671f5a8f1ed856d938283139ccf41d (diff)
refactor(tvix): move logo to //tvix:logo r/6576
Also expose both formats, then use it from
users/tazjin/presentations/tvix-eval-2023.

Change-Id: Id906e8aff5510a7a4f33336326472e86db18ea32
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9280
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index e36883b471..4abf27f463 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -58,6 +58,16 @@ in
     ${depot.tools.depotfmt}/bin/depotfmt Cargo.nix
   '';
 
+  # Provide the Tvix logo in both .webp and .png format.
+  logo = pkgs.runCommand "logo"
+    {
+      nativeBuildInputs = [ pkgs.imagemagick ];
+    } ''
+    mkdir -p $out
+    cp ${./logo.webp} $out/logo.webp
+    convert $out/logo.webp $out/logo.png
+  '';
+
   # Provide a shell for the combined dependencies of all Tvix Rust
   # projects. Note that as this is manually maintained it may be
   # lacking something, but it is required for some people's workflows.