about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-09T12·11+0200
committerclbot <clbot@tvl.fyi>2023-09-09T12·54+0000
commit737846bf17a4baa9a471ee0205825d400b2c8ef2 (patch)
treef03a4ce0e66a24c4d4457bf2d2da4318c70312cf /tvix/default.nix
parent1549f020ee386baf95041ca7886bc564c93ea9d0 (diff)
feat(tvix/store): add :store-protos-go r/6573
This target builds and runs the go tests in that directory, allowing us
to spot regressions as the one fixed in cl/9285.

Change-Id: Ia16c0622f29db343eae7c0386e715b292703bd4f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9286
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: Brian McGee <brian@bmcgee.ie>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 66d4a79d99..e36883b471 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -79,6 +79,14 @@ in
     ];
   };
 
+  # Builds and tests the code in store/protos.
+  store-protos-go = pkgs.buildGoModule {
+    name = "store-golang";
+    src = depot.third_party.gitignoreSource ./store/protos;
+
+    vendorHash = "sha256-7xfXBBU3xJz7ifjk7Owm/byTfCQ8oaZtqXzBKhLqo00=";
+  };
+
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
     inherit cargoDeps;
@@ -103,5 +111,5 @@ in
     '';
   };
 
-  meta.ci.targets = [ "shell" "rust-docs" ];
+  meta.ci.targets = [ "store-protos-go" "shell" "rust-docs" ];
 }