about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-02-14T01·56+0700
committerclbot <clbot@tvl.fyi>2024-02-17T08·06+0000
commitd29330466726ae7263598fd8051894e18745461b (patch)
tree790c2387b8f54413fcddf3d36d38e197564d84a5 /tvix/cli/Cargo.toml
parent87bda3ae7aaf459cd30672164587a3fe246d209a (diff)
feat(tvix/cli): set up tracing[-subscriber] r/7543
No otlp yet, this simply gives us structured log output and a cli
argument for the log level.

Change-Id: Ifaa60bae419640e92baebb6ee59eedd775c769c2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10853
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index f8101300b1..81e28c4c7c 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -19,8 +19,9 @@ clap = { version = "4.0", features = ["derive", "env"] }
 dirs = "4.0.0"
 rustyline = "10.0.0"
 thiserror = "1.0.38"
-tracing = "0.1.37"
 tokio = "1.28.0"
+tracing = "0.1.37"
+tracing-subscriber = { version = "0.3.16", features = ["json"] }
 
 [dependencies.wu-manber]
 git = "https://github.com/tvlfyi/wu-manber.git"