about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-11T15·14+0300
committerclbot <clbot@tvl.fyi>2023-01-11T16·03+0000
commit3045645df07ffdb54f9d2a11ee2e41e31999986f (patch)
treeee768e7a42e4addd6c5f9591163b8b8a683d68ca /tvix/cli/Cargo.toml
parent9382afdb0d7258cee8e7f20d646a85076f38011a (diff)
feat(tvix/cli): implement initial refscan module r/5643
This module implements a ReferenceScanner struct which uses the
aho_corasick crate to scan string inputs for known, non-overlapping
candidates (store paths, in our case).

I experimented with several different APIs, and landed on this version
with an initial accumulator in the scanner. The scanner is
instantiated from the candidates and "fed" all the strings, then
consumed by the caller to retrieve the result.

Right now only things that look vaguely like bytestrings can be fed to
the scanner, there is no streaming support in the API yet.

Change-Id: I7782f0f0df5fc64bccd813aa14712f5525b0168c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7808
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index 099002353d..f3324f2611 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -13,3 +13,4 @@ rustyline = "10.0.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 dirs = "4.0.0"
 smol_str = "0.1"
+aho-corasick = "0.7"