about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-07T21·21+0300
committerIlan Joselevich <personal@ilanjoselevich.com>2024-08-08T08·06+0000
commitf648f17ec3dd9b99d6271f607d62004c321b7c8f (patch)
tree5fe247815cc72c39675cf80f178d9c6865b5c93e /tvix/cli/Cargo.toml
parent000fb856befa667bfc4ac36fe3794f97ad34a1bd (diff)
feat(tvix): Jemalloc -> MiMalloc r/8461
Use the faster and newer MiMalloc memory allocator for all endpoints in
the workspace.

Change-Id: Ic60237284ed168e46ec6e8f28e2710bae4385c6f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12149
Tested-by: BuildkiteCI
Reviewed-by: aspen <root@gws.fyi>
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index 7f93da85d47a..2b624917ee87 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -27,6 +27,7 @@ tokio = "1.28.0"
 tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
 rustc-hash = "2.0.0"
+mimalloc = "0.1.43"
 
 [dependencies.wu-manber]
 git = "https://github.com/tvlfyi/wu-manber.git"
@@ -34,9 +35,6 @@ git = "https://github.com/tvlfyi/wu-manber.git"
 [dev-dependencies]
 expect-test = "1.5.0"
 
-[target.'cfg(not(target_env = "msvc"))'.dependencies]
-tikv-jemallocator = "0.5"
-
 [features]
 default = []
 tracy = ["tvix-tracing/tracy"]