about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-28T21·54+0300
committerclbot <clbot@tvl.fyi>2024-08-29T14·37+0000
commit5a97888d8b9df1815cee3d577ea95a44f188434f (patch)
treebdda1eb049d9e8b607ba71bc9e7cb1e2e5dd769f /tvix/cli/Cargo.toml
parent2945a359b46862b3da79dec37fa8ccb2f751fa8a (diff)
chore(tvix): Migrate members to inherit deps from workspace r/8610
From now on we will add the dependencies and their version in the root
Cargo.toml and in order to enable the dependency for a workspace member
we set `workspace = true` in the member's Cargo.toml.

Change-Id: I9738c1cf99810b7ace87ca712c3ea965ba846e25
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12389
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml32
1 files changed, 15 insertions, 17 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index 9b8bd8c92217..27cd5a6b395c 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -15,25 +15,23 @@ tvix-store = { path = "../store", default-features = false, features = []}
 tvix-eval = { path = "../eval" }
 tvix-glue = { path = "../glue" }
 tvix-tracing = { path = "../tracing" }
-bytes = "1.7.1"
-clap = { version = "4.5", features = ["derive", "env"] }
-dirs = "4.0.0"
-rustyline = "10.1.1"
-rnix = "0.11.0"
-rowan = "*"
-smol_str = "0.2.2"
-thiserror = "1.0.63"
-tokio = "1.39.3"
-tracing = "0.1.40"
-tracing-indicatif = "0.3.6"
-rustc-hash = "2.0.0"
-mimalloc = "0.1.43"
-
-[dependencies.wu-manber]
-git = "https://github.com/tvlfyi/wu-manber.git"
+bytes = { workspace = true }
+clap = { workspace = true, features = ["derive", "env"] }
+dirs = { workspace = true }
+rustyline = { workspace = true }
+rnix = { workspace = true }
+rowan = { workspace = true }
+smol_str = { workspace = true }
+thiserror = { workspace = true }
+tokio = { workspace = true }
+tracing = { workspace = true }
+tracing-indicatif = { workspace = true }
+rustc-hash = { workspace = true }
+mimalloc = { workspace = true }
+wu-manber = { workspace = true }
 
 [dev-dependencies]
-expect-test = "1.5.0"
+expect-test = { workspace = true }
 
 [features]
 default = []