about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-13T17·17+0300
committertazjin <tazjin@tvl.su>2022-12-22T19·09+0000
commitea7d63e177d8a951e30bc00918081eb069e2efb2 (patch)
tree9177f7ff683f2eeef178df2aeda349e52b915c05 /tvix/cli/Cargo.toml
parent4714f8b93998bee9c1b656f0b2358a26d3cf899d (diff)
feat(tvix/cli): implement `NixCompatIO` helper type r/5474
This type allows for temporarily compatibility with the C++ Nix store,
specifically (for now) it gives us the store directory used by Nix and
imports files the same way.

Change-Id: I4767794ef2863eba49661315c63c4e17de946d60
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7587
Reviewed-by: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index ae7cd22210..099002353d 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -12,3 +12,4 @@ tvix-eval = { path = "../eval" }
 rustyline = "10.0.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 dirs = "4.0.0"
+smol_str = "0.1"