about summary refs log tree commit diff
path: root/tvix/castore/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-02T21·09+0300
committerclbot <clbot@tvl.fyi>2024-05-03T08·53+0000
commit37671d3913213d54764f441d6c1473f5e3483e87 (patch)
treeaf9772c07f5895dcaf47382f04d7a0d857633f7d /tvix/castore/default.nix
parentb8e82a42ed018e799f3c2b1cdff680fd04a2a6f2 (diff)
test(tvix/[ca]store): enable bigtable only with "integration" feature r/8070
The emulator and bigtable client are quite big. Remove them from the
default //tvix:shell.

Put the tests behind a `integration` feature flag, and add a variant
with that enabled to CI, and drop the bigtable tools from //tvix:shell.

Change-Id: Ie042097a0d6fc26542faa96c139b77298ccb160a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11582
Reviewed-by: edef <edef@edef.eu>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/castore/default.nix')
-rw-r--r--tvix/castore/default.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/tvix/castore/default.nix b/tvix/castore/default.nix
index edc20ac79d5e..641d88376072 100644
--- a/tvix/castore/default.nix
+++ b/tvix/castore/default.nix
@@ -1,12 +1,23 @@
 { depot, pkgs, ... }:
 
-depot.tvix.crates.workspaceMembers.tvix-castore.build.override {
+(depot.tvix.crates.workspaceMembers.tvix-castore.build.override {
   runTests = true;
   testPreRun = ''
     export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
-    export PATH="$PATH:${pkgs.lib.makeBinPath [pkgs.cbtemulator pkgs.google-cloud-bigtable-tool]}"
   '';
 
   # enable some optional features.
   features = [ "default" "cloud" ];
-}
+}).overrideAttrs (_: {
+  meta.ci.targets = [ "integration-tests" ];
+  passthru.integration-tests = depot.tvix.crates.workspaceMembers.tvix-castore.build.override {
+    runTests = true;
+    testPreRun = ''
+      export SSL_CERT_FILE=${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
+      export PATH="$PATH:${pkgs.lib.makeBinPath [pkgs.cbtemulator pkgs.google-cloud-bigtable-tool]}"
+    '';
+
+    # enable some optional features.
+    features = [ "default" "cloud" "integration" ];
+  };
+})