about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-03-15T20·53+0200
committerclbot <clbot@tvl.fyi>2024-03-16T17·04+0000
commitdbf87f3057ea8468f7bedf8cc61203131fce1f9b (patch)
tree1529498cc55756918dad899ebe1a4307fc2ceaa4 /tvix/castore/Cargo.toml
parent212f5afdcf28ce53006eebcc623a0256ff4aa33c (diff)
chore(tvix): bump tonic to 0.11.0 r/7705
This bumps tonic and surrounding crates to 0.11.x.

We added support for tonic 0.11.x into tokio-listener
(https://github.com/vi/tokio-listener/pull/4), so that's bumped as well.

Change-Id: Icfade5894403228299836fefb21b2f9ae59dbebb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11156
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index 36b2d7ad50..69834ed2e3 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -23,7 +23,7 @@ thiserror = "1.0.38"
 tokio-stream = { version = "0.1.14", features = ["fs", "net"] }
 tokio-util = { version = "0.7.9", features = ["io", "io-util"] }
 tokio = { version = "1.32.0", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
-tonic = "0.10.2"
+tonic = "0.11.0"
 tower = "0.4.13"
 tracing = "0.1.37"
 url = "2.4.0"
@@ -40,7 +40,7 @@ version = "0.2.144"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.10.2"
+version = "0.11.0"
 
 [dependencies.vhost]
 optional = true
@@ -68,7 +68,7 @@ version = "0.2.1"
 
 [build-dependencies]
 prost-build = "0.12.1"
-tonic-build = "0.10.2"
+tonic-build = "0.11.0"
 
 [dev-dependencies]
 test-case = "3.3.1"