about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-03-03T12·40+0200
committerclbot <clbot@tvl.fyi>2024-03-03T15·18+0000
commit8383e9e02e1f762013a652e9a842493a1be5bb60 (patch)
treefbc79f6f10f4b3abf17722701b9a7bcc8d7c3c82 /tvix/castore/Cargo.toml
parent9a7246ea1dac200648976be4558e29c3e9aa7eb7 (diff)
feat(tvix/castore/digests): impl From digest::Output<_> for B3Digest r/7640
This allows calling .into() to get a B3Digest.

Change-Id: I6e63b496413cd00d84acfcd15c7de0f64c79721f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11086
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index 584e64adb8..a4b74cba11 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -5,9 +5,12 @@ edition = "2021"
 
 [dependencies]
 async-stream = "0.3.5"
-blake3 = { version = "1.3.1", features = ["rayon", "std"] }
+async-tempfile = "0.4.0"
+blake3 = { version = "1.3.1", features = ["rayon", "std", "traits-preview"] }
+bstr = "1.6.0"
 bytes = "1.4.0"
 data-encoding = "2.3.3"
+digest = "0.10.7"
 futures = "0.3.30"
 lazy_static = "1.4.0"
 parking_lot = "0.12.1"
@@ -23,8 +26,6 @@ tower = "0.4.13"
 tracing = "0.1.37"
 url = "2.4.0"
 walkdir = "2.4.0"
-bstr = "1.6.0"
-async-tempfile = "0.4.0"
 
 [dependencies.fuse-backend-rs]
 optional = true