about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-26T07·30+0300
committerclbot <clbot@tvl.fyi>2023-09-26T10·07+0000
commit6b02800e486a46e28d6bec79ba3ba94fe006e8c5 (patch)
treec4618647fcae77581956a065d5809f3186e386ad /tvix/castore/Cargo.toml
parent329067f62954f09bcaf87a016f4211fdcf9789dd (diff)
chore(tvix/[ca]store): allow building without tonic-reflection r/6660
 - rename the feature to `tonic-reflection` in both tvix-store and tvix-
   castore.
 - set it to disabled in tvix-castore by default
 - enable it in tvix-store, and pull in tvix-castore with the feature
   enabled.

Change-Id: Ie22833d85569502cae55812f6eeb17a9c15b9e2c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9472
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index 5ad61d08b1..3cf1355e72 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -37,5 +37,5 @@ tempfile = "3.3.0"
 tonic-mock = { git = "https://github.com/brainrake/tonic-mock", branch = "bump-dependencies" }
 
 [features]
-default = ["reflection"]
-reflection = ["tonic-reflection"]
\ No newline at end of file
+default = []
+tonic-reflection = ["dep:tonic-reflection"]
\ No newline at end of file