about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-09-27T14·56+0200
committerclbot <clbot@tvl.fyi>2024-09-27T20·39+0000
commitcaf597db8107d7cb8c4772e83552e9774f85c5c5 (patch)
treeec166388b2d8ddef9b1d42656c4dd14f5f06d501 /tvix/castore/Cargo.toml
parented2bd8885052494bcf208f97e292d746f223a117 (diff)
refactor(tvix): move refscan module to castore r/8724
This is required to add the optional refscanner parameter to the
ingest functions.

Change-Id: Ib40a7287cf857eb55e31e0df309a79474fefb518
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12527
Autosubmit: yuka <yuka@yuka.dev>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index b6752ae25af5..d752802acb69 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -37,6 +37,7 @@ serde = { workspace = true, features = ["derive"] }
 serde_with = { workspace = true }
 serde_qs = { workspace = true }
 petgraph = { workspace = true }
+pin-project = { workspace = true }
 erased-serde = { workspace = true }
 serde_tagged = { workspace = true }
 hyper-util = { workspace = true }
@@ -52,6 +53,7 @@ virtio-queue = { workspace = true, optional = true }
 vm-memory = { workspace = true, optional = true }
 vmm-sys-util = { workspace = true, optional = true }
 virtio-bindings = { workspace = true, optional = true }
+wu-manber = { workspace = true }
 
 [build-dependencies]
 prost-build = { workspace = true }
@@ -66,6 +68,7 @@ hex-literal = { workspace = true }
 rstest_reuse = { workspace = true }
 xattr = { workspace = true }
 serde_json = { workspace = true }
+tokio-test = { workspace = true }
 
 [features]
 default = ["cloud"]