about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-08T11·33+0200
committerclbot <clbot@tvl.fyi>2023-10-08T22·50+0000
commitb6bf3a87f162be158fea1386de1ee87a53c4d65b (patch)
tree30e107ca8dbf80c8fd6321082f65958e0e0fc974 /tvix/castore/Cargo.toml
parentc0376995c9ac4e4b9ca606219035e808fe815d69 (diff)
test(tvix/castore): use tokio-retry for exp backoff r/6742
Rather than using this loop, use exponential backoff while waiting for
the socket path to be created.

Change-Id: I18706a64ce06f8916a07892dfbcd409ac5b3bff1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9568
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index 8f96c3fbf6..4dab3bfa44 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -34,7 +34,8 @@ tonic-build = "0.10.2"
 [dev-dependencies]
 test-case = "2.2.2"
 tempfile = "3.3.0"
+tokio-retry = "0.3.0"
 
 [features]
 default = []
-tonic-reflection = ["dep:tonic-reflection"]
\ No newline at end of file
+tonic-reflection = ["dep:tonic-reflection"]