about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
authorRyan Lahfa <tvl@lahfa.xyz>2023-12-17T00·22+0100
committerclbot <clbot@tvl.fyi>2023-12-17T14·34+0000
commit0ae32d45f690eed8f259ac55b4d0d8bbc006baf2 (patch)
tree23d4b725053bf0a6bc5b41d79ce00a063c90cb38 /tvix/castore/Cargo.toml
parent923a5737e61da020e6d7672c3aebc00db9f44850 (diff)
feat(tvix/castore): simple filesystem blob service r/7228
The simple filesystem `BlobService` enable a user to write blob store
on an existing filesystem using a prefix-style layout in the provided root directory,
e.g. the two first bytes of the blake3 hashes are used as directories prefixes.

Change-Id: I3451a688a6f39027b9c6517d853b95a87adb3a52
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10071
Autosubmit: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index 468ef8ec35..2a421280b8 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -23,6 +23,7 @@ tracing = "0.1.37"
 url = "2.4.0"
 walkdir = "2.4.0"
 bstr = "1.6.0"
+async-tempfile = "0.4.0"
 
 [dependencies.tonic-reflection]
 optional = true