about summary refs log tree commit diff
path: root/tvix/build/protos/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-09T08·49+0200
committerclbot <clbot@tvl.fyi>2023-12-11T21·43+0000
commitfd27d8ddc3a27fd89a3a132343c6a1ad8da3671c (patch)
treeaf891877cb4a0ca5e45f8bc59b29a0f7906dba69 /tvix/build/protos/default.nix
parent3c0a9a949ab71545de23102a8309ad0bea591c1f (diff)
feat(tvix/build): init r/7151
This adds the tvix-build crate, currently only containing a
`tvix_build::proto` module, exposing the data structures defined in
tvix/build/protos.

Change-Id: I75f5d9196969ed0877b1fe640cacfecba0fb2e03
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10235
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/build/protos/default.nix')
-rw-r--r--tvix/build/protos/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/tvix/build/protos/default.nix b/tvix/build/protos/default.nix
new file mode 100644
index 000000000000..138bc2fb713a
--- /dev/null
+++ b/tvix/build/protos/default.nix
@@ -0,0 +1,35 @@
+{ depot, pkgs, ... }: {
+  # Produces the golang bindings.
+  go-bindings = pkgs.stdenv.mkDerivation {
+    name = "go-bindings";
+
+    src = depot.nix.sparseTree {
+      name = "build-protos";
+      root = depot.path.origSrc;
+      paths = [
+        # We need to include castore.proto (only), as it's referred.
+        ../../castore/protos/castore.proto
+        ./build.proto
+        ./rpc_build.proto
+        ../../../buf.yaml
+        ../../../buf.gen.yaml
+      ];
+    };
+
+    nativeBuildInputs = [
+      pkgs.buf
+      pkgs.protoc-gen-go
+      pkgs.protoc-gen-go-grpc
+    ];
+
+    buildPhase = ''
+      export HOME=$TMPDIR
+      buf lint
+      buf format -d --exit-code
+      buf generate
+
+      mkdir -p $out
+      cp tvix/build/protos/*.pb.go $out/
+    '';
+  };
+}