about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-26T16·19+0200
committerclbot <clbot@tvl.fyi>2024-05-26T19·46+0000
commitca542440a5ac6d48f962a26febffcfc17514ad5d (patch)
tree5c29e17879214196ae835173466c949a2cd5a8b3 /tvix/build/Cargo.toml
parent9586e5c30da23dd25d404d075a64161689f8cc02 (diff)
fix(tvix/build): tonic-reflection feature needs castore with it too r/8173
If building tvix-build with the tonic-reflection feature, it needs
to import `tvix_castore::proto::FILE_DESCRIPTOR_SET`, which is only
available if tvix-castore is built with the `tonic-reflection` feature.

Change-Id: I355b4c5b4c1333d5cc56335de47ad5d2f1db6337
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11716
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index cf25465cca..c8123c2617 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -27,7 +27,7 @@ tonic-build = "0.11.0"
 
 [features]
 default = []
-tonic-reflection = ["dep:tonic-reflection"]
+tonic-reflection = ["dep:tonic-reflection", "tvix-castore/tonic-reflection"]
 
 [dev-dependencies]
 rstest = "0.19.0"