about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-15T17·15+0200
committerclbot <clbot@tvl.fyi>2024-01-15T18·49+0000
commit170e0cdfadd96176595c47b573d0a1f27a7c734b (patch)
tree1a2a591b1f162062096aecc3f124f25f433e34c4 /tvix/build/Cargo.toml
parent5aa9b29d8cdf870ee6f3ad01a874604ff9f93e45 (diff)
feat(tvix/build): add from_addr method r/7386
This allows constructing a BuildService from a URI, similar to how it's
done in tvix-[ca]store.

Change-Id: Ib962b329535c6c7e378ab7ac7f4dd254366497b3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10630
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 52dcf0abec..08102a66be 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -8,9 +8,11 @@ bytes = "1.4.0"
 itertools = "0.12.0"
 prost = "0.12.1"
 thiserror = "1.0.56"
+tokio = { version = "1.32.0" }
 tonic = { version = "0.10.2", features = ["tls", "tls-roots"] }
 tvix-castore = { path = "../castore" }
 tracing = "0.1.37"
+url = "2.4.0"
 
 [dependencies.tonic-reflection]
 optional = true